Issue with screenings via ComplyAdvantage

Incident Report for Meo

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 14:43 CET

Investigating

We are currently investigating the issue.
Posted Mar 04, 2026 - 13:39 CET
This incident affected: Services and Applications (ComplyAdvantage Integration).