Issue with ComplyAdvantage screenings

Incident Report for Meo

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 11:41 CEST

Monitoring

ComplyAdvantage service seems to be operational again, but we are keeping an eye on the logs for the next period to confirm the stability.
Posted Sep 10, 2025 - 16:20 CEST

Investigating

Our calls to ComplyAdvantage are timing out. We suspect that ComplyAdvantage is having issues. We are in contact with them to resolve the issue.
Posted Sep 10, 2025 - 16:10 CEST
This incident affected: Services and Applications (ComplyAdvantage Integration).