OpenCorporates missing legal owner information
Incident Report for Meo
Resolved
OpenCorporates fixed the issue on their end.
Posted May 18, 2022 - 08:28 CEST
Identified
OpenCorporates began to fail part of the API calls for our integration. We have temporary removed those elements from the API integration, so the integration is still working (albeit in a limited mode). We have contacted OpenCorporates for a solution.

Currently, information on the legal owners is not retrieved from OpenCorporates.
Posted May 16, 2022 - 12:04 CEST
This incident affected: Third-Party Providers (OpenCorporates).