Experiencing issues with Passport validation

Incident Report for Meo

Resolved

This incident has been resolved.
Posted Sep 20, 2023 - 15:28 CEST

Update

The issue has been solved by our 3rd party service.
Posted Sep 20, 2023 - 14:30 CEST

Update

We are continuing to investigate this issue.
Posted Sep 20, 2023 - 14:17 CEST

Investigating

We are currently experiencing irregularities with the 3rd party service for passport validation and are investigating the issue.
Posted Sep 20, 2023 - 14:15 CEST
This incident affected: Services and Applications (Onboarding Wizard).