ID documents cannot be uploaded
Incident Report for Meo
Resolved
This incident has been resolved
Posted Jul 15, 2024 - 16:24 CEST
Identified
We are aware of an issue with uploading passports. We are implementing a fix.
Posted Jul 15, 2024 - 14:21 CEST
This incident affected: Services and Applications (Onboarding Wizard).