Unable to open documents

Incident Report for Meo

Resolved

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 14:02 CEST

Investigating

We are currently investigating the issue with unable to open documents in the platform.

As a workaround, it is possible to download the document to display it on your own device: https://cleanshot.com/share/kvBtcXd4
Posted Jul 09, 2026 - 12:55 CEST
This incident affected: Services and Applications (Business Account).